/ / / Потенциальная угроза в модуле Minify
август 10 2013

Потенциальная угроза в модуле Minify

Проблема: Недостаточная фильтрация данных в модуле сжатия файлов Minify входящем в состав DLE (https://code.google.com/p/minify/), которая может позволить при определенных настройках серверного ПО читать содержимое файлов.

Ошибка в версии: 8.5 - 10.0

Степень опасности: Высокая

Для исправления откройте файл: /engine/classes/min/index.php и в самое начало файла после строчки:
<?php

добавьте:
if (isset($_GET['f'])) { 
       $_GET['f'] = str_replace(chr(0), '', (string)$_GET['f']); 
} 

Дистрибутив версии 10.0 на нашем сервере обновлен.
Календарь
«    Декабрь 2016    »
ПнВтСрЧтПтСбВс
 1234
567891011
12131415161718
19202122232425
262728293031 
Опрос на сайте
Совершаете ли вы покупки в интернет?

Популярные новости
Архив новостей
Декабрь 2016 (3)
Ноябрь 2016 (3)
Октябрь 2016 (2)
Сентябрь 2016 (3)
Июль 2016 (1)
Июнь 2016 (2)