Главная страница / Информация / Обновление WYSIWYG редактора для версии 9.6
май 20 2012

Обновление WYSIWYG редактора для версии 9.6


Дорогие друзья,

Представляем вам патч для нового WYSIWYG редактора, представленного в версии 9.6. В данном патче исправляются некоторые проблемы, обнаруженные в редакторе, связанные с форматированием текста, исправлены проблемы с удалением части контента при определенном форматировании текста. Обновленная версия редактора не вносит никаких новых функций, и исправляет только различные обнаруженные ранее проблемы. Установка обновленной версии WYSIWYG редактора необходима только пользователям версии DataLife Engine 9.6, и только тем кто использует в своей работе WYSIWYG редактор.

Внимание!

Просмотр данной информации доступен только пользователям имеющим действующую лицензию на скрипт. Если вы уже приобретали скрипт, то вам необходимо зайти на сайт под своим клиентским аккаунтом. Если срок вашей лицензии истек, то вы можете продлить ее в своем профиле на нашем сайте
Данный патч предназначен только для версии 9.6. Для установки патча скачайте и распакуйте архив, скопируйте содержимое архива на ваш сервер, после чего обязательно очистите кеш браузера, чтобы изменения вступили в силу.

Дистрибутив версии 9.6 обновлен.

Комментарии

  1. maks1192 (Посетители)

    20 мая 2012 03:30 20 комментариев
    Спасибо за обновку.

    В Опере вообще не возможно работать с текстом.. редактируешь, пишешь и т.д. и безконца что-то вставляет то что не просят, вставялет т.ги и т.д. в общем, косячная Опера.. Пользуюсь Хромом, нормально. Но млин, не получается уйти с Оперы =)) привык к ней.
  2. Cox (Посетители)

    20 мая 2012 12:12 11 комментариев
    Спасибо.
  3. DeeMon (Посетители)

    20 мая 2012 18:43 54 комментария
    В дистрибе 9.6 уже исправления есть или обновлять ?
  4. Opium (Посетители)

    20 мая 2012 18:59 2 комментария
    Цитата: DeeMon
    В дистрибе 9.6 уже исправления есть или обновлять ?

    Невнимательны. Написано же, и выделено:
    Дистрибутив версии 9.6 обновлен.
  5. Assassin674 (Клиенты)

    20 мая 2012 19:19 12 комментариев
    Благодарю, за обновленный редактор smile
  6. aleksm (Посетители)

    21 мая 2012 01:46 1 комментарий
    Спасибо!
  7. GTS_gelezn (Клиенты)

    21 мая 2012 07:07 70 комментариев
    Кнопочки "Вырезать" и "вставить" из редактора пропали, оказывается некоторые ими пользовались, жалуются что нехватает

    И в опере, раньше выделяешь новость в редакторе. Её можно было вставить в другую и внести исправления, т.е. использовать одну новость как шаблон. Форматирование полностью сохранялось.
    Теперь при вставке части пропадают. Картинки или наоборот текст.
  8. celsoft (Администраторы)

    21 мая 2012 07:15 3 371 комментарий
    Цитата: GTS_gelezn
    И в опере, раньше выделяешь новость в редакторе. Её можно было вставить в другую и внести исправления, т.е. использовать одну новость как шаблон. Форматирование полностью сохранялось.Теперь при вставке части пропадают. Картинки или наоборот текст.

    Какие именно части пропадают? Давайте конкретный пример, с какой страницы и откуда копируется текст, чтобы можно было проверить.
  9. Anbrave (Посетители)

    21 мая 2012 10:24 13 комментариев
    Я даже не знал, что вообще кто-то пользуется им.
  10. GTS_gelezn (Клиенты)

    21 мая 2012 10:50 70 комментариев
    Цитата: celsoft
    Давайте конкретный пример, с какой страницы и откуда копируется текст, чтобы можно было проверить.

    Версия 9.6, обновление редактора установлено, кеш браузера отчищен.
    Картинки пропадают со слов авторов (я публикацией не занимаюсь).

    Вот что получилось у меня.
    В IE 9 можно выделить текст с картинкой в краткой версии новости, нажать добавление новости (ссылка в разделе "панель управления" шаблона сайта), правой кнопкой, вставить.
    У меня вставляется и картинка и текст, правда вокруг картинки почему то красная рамка.

    Возможно так картинки вставлялись и в опере, а теперь нет.
    Я попробовал в опере.
    Копирую из краткого описания картинку по центу и анонс под ней. Вставляется только текст, с отступом сверху равным ширине картинки, но вместо картинки этот отступ забит переносами.
    Возможно пользователь имел в виду это.

    http://s09.radikal.ru/i182/1205/a6/d4c885c4b4aa.jpg
    Если такое выделение скопировать, тоже ничего не вставится.

    Еще в опере, если шаблон не резиновый, не влазят все кнопки редактора, это тоже видно на картинке.
    В других браузерах (IE, Лиса) все нормально, не влезающие кнопки переносятся на новую строку.

    Я понимаю, что это может показаться мелочами. Я бы например просто скопировал ШТМЛ код да и все, но с движком работают журналисты, которым до HTML и прочих премудростей дела нет. И копировать шаблонный анонс, потом подправив пару строк им естественно удобней и быстрее, чем каждый раз заново загружать/вставлять картинку.
    Кнопочки вырезать вставить исчезли и то вон неудобство, сказали что это был основной инструмент. Привыкли как в ворде на картинки жать...


    Попросил пользователей размещающих новости делать скрины косяков, если сделают будут картинки.

    Цитата: Anbrave
    Я даже не знал, что вообще кто-то пользуется им.

    Дык в том и фишка, что человек вообще без познаний в этой области спокойно может добавлять и оформлять материалы.
    Я когда поставил, потыкался, честно говоря приятно порадовался изменениям, во дуваю как им удобно будет теперь. меню скомпанованно, какие картинки загрузили - видно.
    А на следующий день меня ошарашили жалобами :)
  11. GTS_gelezn (Клиенты)

    21 мая 2012 11:21 70 комментариев
    Еще с загрузкой картинок косячек.
    Картинка 2048 на 1536 пикселей, выбираем грузить с URL.
    Галочка уменьшать до 200 по ширине
    Нажимаю загрузить и там зависает ждите........
    Не дожидаемся. Опять открываем файлы загруженные для новости, оказывается, что картинка загрузилась, но уменьшенной копии не сделано. При нажатии на неё можно вставить в новость оригинал, а галочек с выбором - оригинал или уменьшиная копия - нет.
  12. celsoft (Администраторы)

    21 мая 2012 11:30 3 371 комментарий
    Цитата: GTS_gelezn
    Еще с загрузкой картинок косячек.Картинка 2048 на 1536 пикселей, выбираем грузить с URL.Галочка уменьшать до 200 по ширинеНажимаю загрузить и там зависает ждите........Не дожидаемся. Опять открываем файлы загруженные для новости, оказывается, что картинка загрузилась, но уменьшенной копии не сделано. При нажатии на неё можно вставить в новость оригинал, а галочек с выбором - оригинал или уменьшиная копия - нет.

    Данная проблема никак не связана с редактором, у вас не хватило оперативной памяти для обработки картинки. Увеличивайте память выделенную на PHP процесс в настройках скрипта.

    Цитата: GTS_gelezn
    Возможно так картинки вставлялись и в опере, а теперь нет.Я попробовал в опере.Копирую из краткого описания картинку по центу и анонс под ней. Вставляется только текст, с отступом сверху равным ширине картинки, но вместо картинки этот отступ забит переносами.Возможно пользователь имел в виду это.

    Тоже никак не связано с редактором, и в старом редакторе было все точно также, вставка контента напрямую зависит в данном случае от браузера, и а не от редакторов, как браузер вставит, так оно и будет. И здесь изменения произошли в браузере, а не в редакторе. Вот например старый редактор http://www.tinymce.com/tryit/full.php который был ранее в DLE, скопируйте в него текст в опере и увидите все тоже самое без картинок. Ваши пользователи заблуждаются в данном случае.
  13. GTS_gelezn (Клиенты)

    22 мая 2012 06:03 70 комментариев
    Возможно, порекомендовал уменьшать картинки.

    Еще у меня проблема со вставкой ссылок (Firefox)
    Например такого вида:
    .....param1=value1¶m2=value2
    Если выделить слово, нажать на иконку вставки ссылки и вставить - все нормально. Слово становится ссылкой.

    Но бывает, пользователям нужно показать и саму ссылку. Вставляем её в редактор, выделяем её, нажимаем на иконку вставки ссылки и вставляем её же.
    В итоге получаем ссылку битую. При наведении мыши на ссылку браузер снизу показывает её адрес, куда планирует перейти и вместо
    .......param1=value1¶m2=value2
    видим
    .......param1=value1¶m2=value2
    и переходит по несуществующему адресу

    обычно, если в html коде используется & amp; браузер все равно показывает &

    Мда, тут вообще извратило ссылки, а тэга для вставки исходного кода нет. Короче речь идет о & и его замене на & В первой ссылке просто & во второй видим & amp; (без пробела естественно, пробел чтоб тут не заменило).

    Посмотрел как это пишется в базу.

    В базе лишний дубль & amp;amp;
    Плюс жесь со ссылкой. Новость сколько раз редактировал и сохранял, столько раз ссылка и продублирована
  14. StanislavGornakov (Посетители)

    22 мая 2012 09:55 6 комментариев
    Удивлен тем, что еще кто-то до сих пор пользуются Оперой :)
    Честно говоря 1.7% мирового рынка этого браузера, говорит о том, что его уже давно пора "выбросить" на свалку истории, но на любителя конечно все это.
  15. GTS_gelezn (Клиенты)

    22 мая 2012 13:10 70 комментариев
    Цитата: StanislavGornakov
    Честно говоря 1.7% мирового рынка этого браузера, говорит о том, что его уже давно пора "выбросить"

    По такой логике себе непременно нужно ставить IE который по прежнему удерживает большую часть рынка :)
    Сейчас якобы хром вырвался вперед, но прошлый раз он вырвался вперед на пару дней, так что доли примерно равны.
  16. celsoft (Администраторы)

    22 мая 2012 15:01 3 371 комментарий
    Цитата: GTS_gelezn
    Еще у меня проблема со вставкой ссылок (Firefox)Например такого вида:.....param1=value1¶m2=value2Если выделить слово, нажать на иконку вставки ссылки и вставить - все нормально. Слово становится ссылкой.Но бывает, пользователям нужно показать и саму ссылку. Вставляем её в редактор, выделяем её, нажимаем на иконку вставки ссылки и вставляем её же.В итоге получаем ссылку битую. При наведении мыши на ссылку браузер снизу показывает её адрес, куда планирует перейти и вместо.......param1=value1¶m2=value2видим.......param1=value1¶m2=value2и переходит по несуществующему адресуобычно, если в html коде используется & amp; браузер все равно показывает &Мда, тут вообще извратило ссылки, а тэга для вставки исходного кода нет. Короче речь идет о & и его замене на & В первой ссылке просто & во второй видим & amp; (без пробела естественно, пробел чтоб тут не заменило).Посмотрел как это пишется в базу.

    Нет никаких проблем. Вставлять нужно ссылки правильно. Экранированный апресанд это для исходного кода HTML, а вы экранированный амперсанд вставляете в саму ссылку в визуальной части. тем самым добавляете изначально битую ссылку. Нужно добавлять правильную ссылку где просто стоит & а не & amp;, потому как & amp; это для исходного кода HTML, а ссылку вы вставляете в визульной части.
  17. GTS_gelezn (Клиенты)

    22 мая 2012 16:18 70 комментариев
    Цитата: celsoft
    Нет никаких проблем. Вставлять нужно ссылки правильно. Экранированный апресанд это для исходного кода HTML, а вы экранированный амперсанд вставляете в саму ссылку в визуальной части. тем самым добавляете изначально битую ссылку. Нужно добавлять правильную ссылку где просто стоит & а не & amp;, потому как & amp; это для исходного кода HTML, а ссылку вы вставляете в визульной части.

    В том то и дело, что я не вставлял амперсанд.
    Я вставляю в редактор текст, ссылки содержащий &
    Пока это не ссылка, просто текст.
    Выделяю этот текст, нажимаю иконку вставки ссылки и вставляю в поле адрес её же.

    Букв amp в моей ссылке нет вообще.
    А в итоге, в базе amp 2 раза
  18. VexterXS (Клиенты)

    22 мая 2012 16:55 11 комментариев
    А можно отдельно редактор из 9.6 на 9.5 поставить?
  19. GTS_gelezn (Клиенты)

    22 мая 2012 17:04 70 комментариев
    Даже без всяких сложностей.
    - Нажимаю добавить новость
    - Вставляю ссылку содержащую & (просто скопировать из адресной строки браузера и Ctr+V в поле для полной или краткой новости)
    - Нажимаю кнопку просмотр

    В просмотре ссылка битая.
    Смотрю html код, там блабла & amp;amp; бла бла
  20. celsoft (Администраторы)

    22 мая 2012 17:21 3 371 комментарий
    GTS_gelezn,
    Сделал все тоже самое, ссылка не битая. Напишите какую ссылку вы вставляете, а также браузер и версию браузера которые вы используете, чтобы я смог повторить ваши действия в точности как и вы делаете. И еще:
    Вставляем её в редактор, выделяем её, нажимаем на иконку вставки ссылки и вставляем её же.

    Это что за непонятное хитрое действие и главное непонятно зачем делать столько лишних движений. Зачем вы ее в редактор ставите и выделяете, просто нажимаете на кнопку ссылки и вставляете ссылку в открывшееся окно, ничего в редакторе не должно быть выделено, просто чтобы курсор стоял в нужном месте. Все вставиться автоматически.

    Цитата: VexterXS
    А можно отдельно редактор из 9.6 на 9.5 поставить?

    Нет.
  21. GTS_gelezn (Клиенты)

    22 мая 2012 17:35 70 комментариев
    Браузер любой
    Ссылка адрес видеоподкаста со страницы http://www.tv.k26.ru/index.php?newsid=4554
    Если вставить её прямо в браузер - откроется правильный rss, c видео.
    Если вставить в новость и перейти по ссылке из новости - открывается аудиоподкас, это rss по умолчанию если не переданы параметры или переданы левые.

    Там в новости все работает потому что вручную была подправлена ссылка в базе.

    Цитата: celsoft
    Это что за непонятное хитрое действие и главное непонятно зачем делать столько лишних движений. Зачем вы ее в редактор ставите и выделяете, просто нажимаете на кнопку ссылки и вставляете ссылку в открывшееся окно, ничего в редакторе не должно быть выделено, просто чтобы курсор стоял в нужном месте. Все вставиться автоматически.

    Ну вот такая логика :) Если просто вставить, ожидают просто текст. Этот текст нужно сделать еще и кликабельным. Значит нужно выделить и снабдить ссылкой как обычно.
  22. celsoft (Администраторы)

    22 мая 2012 18:45 3 371 комментарий
    GTS_gelezn,
    Ничего не понимаю, все у меня работает. Вставляю эту ссылку без проблем, все прекрасно работает, ничего лишнего не добавляется RSS c видео открывается без проблем. Проверил на IE, FF, Chrome, ни в одном проблемы не возникло.
  23. VexterXS (Клиенты)

    22 мая 2012 21:26 11 комментариев
    celsoft,а вот еще с таблицами байда. Как сделать границы у таблицы, соданной в редакторе? Ставлю толщину, цвет и нажимаю где выбор числа ячеек. В итоге в редакторе таблица пунктиром, а на сайте ее вообще не видно.
  24. celsoft (Администраторы)

    22 мая 2012 23:13 3 371 комментарий
    Цитата: VexterXS
    celsoft,а вот еще с таблицами байда. Как сделать границы у таблицы, соданной в редакторе? Ставлю толщину, цвет и нажимаю где выбор числа ячеек. В итоге в редакторе таблица пунктиром, а на сайте ее вообще не видно.

    Пунктир в таблице это не не бордюр таблицы, это границы таблицы чтобы вы видели что редактировать, а бордюр устанавливается соответствующими кнопками которые в окне редактирования таблицы. Курсор при этом должен быть внутри нужной таблице или ячейке, а не где за пределами таблицы. Когда вы установите границы для таблице, то они перестанут быть пунктирами непосредственно в редакторе.
  25. GTS_gelezn (Клиенты)

    23 мая 2012 01:44 70 комментариев
    Цитата: celsoft
    Ничего не понимаю, все у меня работает. Вставляю эту ссылку без проблем, все прекрасно работает, ничего лишнего не добавляется RSS c видео открывается без проблем. Проверил на IE, FF, Chrome, ни в одном проблемы не возникло.

    Вот видео косяка http://zalil.ru/33290066
    В личку скинул логин и пароль для тестового юзера, можно попробовать проделать тож самое.
    Могу выслать файлы движка какие потребуется.

    Сегодня еще попробую поставить движок на другом сервере и посмотреть, чего будет там.
  26. GTS_gelezn (Клиенты)

    23 мая 2012 02:48 70 комментариев
    На другом сервере аналогично.
    Если в редакторе нажать исходный HTML код, там & заменяется & amp; корректно, один раз.
    Если из ссылки, вначале удалить http:// (она начинается с www) ссылка все равно формируется но верно, лишнего amp нет.

    Как мне кажется, редактор уже при вставке в него ссылки заменяет & на & amp; А потом еще движок, если находит в тексте новости ссылку, делает это.
  27. GTS_gelezn (Клиенты)

    23 мая 2012 03:07 70 комментариев
    Кстати если в настройках скрипта отключить автоматическую конвертацию ссылок в кликабельные, такую ссылку, с одинаковыми текстом и адресом перехода, сделать не удается вообще. Даже если в иконке вставки ссылки сделать одинаковые и адрес и заголовок.

    В исходном НТМЛ коде редактора все нормально < a href="link" >link< /a >
    а в предпросмотре новости получается < a title="link" >link< /a >
  28. mkkuzbass (Посетители)

    23 мая 2012 11:23 6 комментариев
    tinymce был юзабельнее.. хотя конечно не такой красивый.
  29. celsoft (Администраторы)

    23 мая 2012 12:00 3 371 комментарий
    Цитата: GTS_gelezn
    Кстати если в настройках скрипта отключить автоматическую конвертацию ссылок в кликабельные, такую ссылку, с одинаковыми текстом и адресом перехода, сделать не удается вообще. Даже если в иконке вставки ссылки сделать одинаковые и адрес и заголовок.В исходном НТМЛ коде редактора все нормально < a href="link" >link< /a >а в предпросмотре новости получается < a title="link" >link< /a >

    Подозреваю что в своих тестированиях, вы пытаетесь поставить ссылку на админпанель скрипта в своей новости. DLE не допускает публикаций в новости ссылок на собственную админпанель в целях безопасности. Так было всегда и во всех версиях скрипта.
  30. mkkuzbass (Посетители)

    23 мая 2012 13:54 6 комментариев
    в новом редакторе невозможно за раз вставить полные изображения, приходится по каждому нажимать. выбрать "вставить как - Оригинальное изображение" - вставить..

    если изображения два, то это не беда. а вот когда 10...

Информация

Комментирование публикаций доступно только пользователям имеющим действующую лицензию на скрипт. Если вы уже приобретали скрипт, то вам необходимо зайти на сайт под своим клиентским аккаунтом.

Календарь

«    Июль 2020    »
ПнВтСрЧтПтСбВс
 12345
6789101112
13141516171819
20212223242526
2728293031 

Опрос на сайте

Совершаете ли вы покупки в интернет?